How can I stop the screen from blacking out

I have an external monitor with 2 HDMI ports. When I step away from the computer, I lock the screen so my cat doesn’t mess stuff up when she rolls on the keyboard.

The problem is - the screen almost immediately goes black, and then my screen switches to my other computer, so I have to switch my monitor manually to go back to Unity. It’s very annoying. I’ve looked in System Settings, Tweak, and Unity-Tweak (why so many places?) but nothing seems to change this behavior. Help!

So, after a few days, it spontaneously started working. I’m not going to complain.

It turns out it wasn’t fixed, just works sporadically. I’ve discovered that I often hit an extra return key. So When I enter super+L followed by a return, it always works correctly. When I enter super+L and no key, or any other key, it will hibernate. Everything else works great, I can remember to hit enter when I lock the screen. But I think it shows the config is wrong somewhere.